Sign in to follow this  
abador

cyberpower 375SL service manual?

Recommended Posts

I bought this battery backup system from a thrift store for $4.99 hoping to have something that I can use to power some important items when the power goes out. once I got it home I charged the battery for more than the recommended 8 hours and the battery still does not kick in when I unplug the device. Also when I plug the system back in it starts turning on and off until I remove the load from the battery plugs. Does anyone have any idea what could be wrong with it? There is a label on the outside stating that there are no serviceable parts inside but I assume I might be able to solder and unsolder stuff to the circuit board. Also if someone can find a service manual that would be very helpful.

Share this post


Link to post
Share on other sites

I cracked the unit open and checked the voltage at the battery with the unit unplugged and then with it plugged in. Unplugged it reads under a volt but when it is plugged in the circuit reads 13 volts. I figure this means the charging circuit must be good but the battery is bad. The battery is a 12 volt battery. I am pretty certain that the battery is bad but could this cause it to keep switching on and off when the unit is plugged back in? Also I'm pretty sure it is lead-acid.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this