Sign in to follow this  

The procedure of STM32F103VCT6 cannot be downloaded by ISP

Recommended Posts


These days I met a problem about STM32F103VCT6.

After the second edition of the STM32F103VCT6 single-chip microcomputer system I made recently, I found that I could not download by ISP, and the isps did not change the circuit line completely compared with the first version. However, it is ok to use the SW download mode, and the ISP serial port can communicate normally when the program is good. Under the ISP mode, I shook hands with serial assistants send bootloader byte 0 x7f, returned to 0 x7f and 0 x79 two bytes, while the normal board should only receive a byte 0 x79. Why is this 0 x7f, has anyone encountered the same situation, and how to solve. 

The methods I have tried:
1. Replace single chip microcomputer, max232 and peripheral capacitance, serial port signal driver IC, etc
2. The power circuit has also been changed, and the first plate of power supply has been tried.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this